Engagio web application unavailable
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted Mar 02, 2020 - 14:29 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2020 - 14:15 PST
Update
We are continuing to investigate this issue.
Posted Mar 02, 2020 - 13:55 PST
Investigating
We are currently investigating this issue.
Posted Mar 02, 2020 - 13:37 PST
This incident affected: Platform.