Data sync delays
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 19:54 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2020 - 12:40 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 18, 2020 - 08:22 PDT
Investigating
We are currently experiencing data sync delays. All customer data will continue to be synced but will not show up in the app until the issue has been resolved.
Posted Jun 18, 2020 - 07:46 PDT
This incident affected: Platform.