Delay in communication history for customers using G-Suite
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 25, 2019 - 16:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Mar 25, 2019 - 15:28 PDT
Investigating
We are currently experiencing delay in processing emails in communication history for customers using G-Suite.
Posted 6 months ago. Mar 25, 2019 - 11:53 PDT
This incident affected: Platform.