Engagio web application unresponsive
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 14:09 PST
Identified
Engagio web application was unresponsive between 2:05PM and 2:09PM. The issue was identified and appropriate fix was implemented.
Posted Jan 10, 2020 - 14:05 PST
This incident affected: Platform.