Playbook - slow page load time
Incident Report for Engagio
Resolved
We have deployed the fix and confirmed it's resolved the issue.
Posted 8 months ago. Jan 15, 2018 - 19:01 PST
Update
Engineers have made a fix and it's being deployed.
Posted 8 months ago. Jan 15, 2018 - 18:43 PST
Identified
Identified a possible issue with a frontend component. Engineers are actively working on a fix.
Posted 8 months ago. Jan 15, 2018 - 18:26 PST
Investigating
We're investigating the cause and will provide an update as soon as possible.
Posted 8 months ago. Jan 15, 2018 - 18:00 PST