Chrome extension not available on Google Chrome store
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 11, 2018 - 07:20 PDT
Identified
We have identified an issue with our chrome extension, not being available for download on Chrome store. We are working with Google support to bring back the listing as soon as possible. At the moment this only affects users trying to download the extension. The extension continuous to work for users who already have it downloaded.
Posted 4 months ago. Jun 08, 2018 - 11:04 PDT
This incident affected: Platform.