Slow page load time on Platform
Incident Report for Engagio
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 27, 2017 - 11:43 PST
Monitoring
The service issue has been addressed. The page load times should be back to normal. We are actively monitoring the service for incident resolution.
Posted 10 months ago. Nov 27, 2017 - 11:09 PST
Identified
app.engagio.com is currently experiencing slow page load times across all pages. We have identified the cause and will provide an update as soon as possible.
Posted 10 months ago. Nov 27, 2017 - 10:58 PST